Page 1 of 1

osis2epub1: Can't continue with conversion

PostPosted: 2015-12-08T16:48:44+00:00
by richardprins
Hi, I tried to use the osis to epub workflow, but as soon as I open my osis xml file in the file browser opened when i run, the program crashes and I cannot continue on with the conversion. I am using ubuntu 15.10. Any tips would be much appreciated.

Re: osis2epub1: Can't continue with conversion

PostPosted: 2015-12-09T22:56:21+00:00
by skreutzer
Hi Richard,

are you sure it actually crashes? Have you seen this video already? Corresponding to 1:08, did you run the setup? Corresponding to 1:27, does the second dialog for selecting an EPUB generator backend not appear? If you call any of the starter shell scripts, they'll write a small log file named log.txt in the same directory as the shell script, could you please look into it and try to figure out what might have went wrong? If there's no problem immediately apparent to you, please feel free to send me this log file (if present, hopefully). Yes, the package requires Java, at least version 1.6 or higher, but it seems you've already statisfied this dependency ;-)

To make a first assumption about what might have gone wrong, I fear it might be that your OSIS input file is invalid. Are you a little familiar with the topic of technical validity, data quality, semantics etc.? If the OSIS file is invalid, this would mean the file isn't conforming to the OSIS standard, therefore my workflow doesn't continue to work with it because otherwise it might run into all kinds of terrible problems. If this would be the case, the next question would be where you've got the OSIS file from, and how we might fix it.

Besides this initial trouble of running the program, if you want certain improvements, certain extensions, make suggestions to improve the usability (for example, more error reporting would have helped), translation of the program, I would be glad to work on it whenever time permits. Do you have a specific project for converting OSIS to EPUB? Also, don't forget to check the resulting EPUB file (with this GUI for epubcheck for instance) and please report any errors epubcheck discovers. Epubcheck could be integrated into the workflow in a future version of the software package, so the workflow would refuse to generate the EPUB result if it wouldn't comply to the EPUB standard


Re: osis2epub1: Can't continue with conversion

PostPosted: 2015-12-13T20:32:01+00:00
by richardprins
Dear Stephan, I emailed you, but for others who might have the same problem:
I managed to get a working OSIS file by converting the bblx file with the Bible Drop Box:
The option: Single OSIS XML file (using our own Python3 code—experimental), provided me with a functioning OSIS file.
Although it started working on the epub as well, it only produced the HTML files, but not the epub.
This is the html to epub log:

html2epub1: Reading configuration.

html2epub1: Validating 'C:\free-scriptures-22-windows\tools\workflows\haggai2epub1\temp\.\components\title.xhtml'.

html2epub1: Can't validate XHTML 1.0 file - schema 'xhtml1-strict.xsd' is missing.

file_picker1 Copyright (C) 2014-2015 Stephan Kreutzer

This program comes with ABSOLUTELY NO WARRANTY.

This is free software, and you are welcome to redistribute it

under certain conditions. See the GNU Affero General Public

License 3 or any later version for details. Also, see the source code

repository ... ublishing/

or the project website

file_picker1: 'C:\Users\Richard\Google Drive\Boeken\Dostoievski - El Jugador.epub' selected.

haggai2epub1 workflow: Can't copy 'C:\free-scriptures-22-windows\tools\workflows\haggai2epub1\temp\out.epub' to 'C:\Users\Richard\Google Drive\Boeken\Dostoievski - El Jugador.epub' because 'C:\free-scriptures-22-windows\tools\workflows\haggai2epub1\temp\out.epub' doesn't exist.

PS: I only got the free-scriptures program running on windows by executing it from my C:\free-scriptures folder as administrator, it did not work from the downloads folder.

Re: osis2epub1: Can't continue with conversion

PostPosted: 2015-12-13T20:34:09+00:00
by richardprins
I think I see (part of) the problem
In the log you see this line:
html2epub1: Validating 'C:\free-scriptures-22-windows\tools\workflows\haggai2epub1\temp\.\components\title.xhtml'.

And that \.\ shouldn't be there.

I had similar problems with other parts of the program running it from my downloads instead of my C:\freescriptures folder (on windows).

Re: osis2epub1: Can't continue with conversion

PostPosted: 2015-12-14T10:05:26+00:00
by skreutzer
Thank you for this error report! The \.\ should be fine, as . is a reference to the current directory, so it has basically no effect. The problem is caused by whitespaces in the path, but I found a solution for it, which is provided in the latest release. Did you encounter the same error (“schema 'xhtml1-strict.xsd' is missing”) on Ubuntu? I'm really interested in getting it to work under Unix-like operating systems, as they're the main platform, while fixing errors on other operating systems as they occur.

richardprins wrote:using our own Python3 code—experimental

Robert Hunt might be interested in those experimential modifications, did you contact him already? Sounds like you've already found their source code repository, you may just fork it and later create a pull request, if those modifications are of use for others as well. Unfortunately, their license is just GPLv3 and not AGPLv3, where the former is insufficient for software that is run online, so it depends on if you're willing to invest time for adjustments which may gradually slip away into proprietary practice.